Answered step by step
Verified Expert Solution
Link Copied!

Question

1 Approved Answer

Performance Assessment - FTP, TFTP, Telnet, and SSH Task 1 - Setting up the network Make sure to use this unique network number

Performance Assessment - FTP, TFTP, Telnet, and SSH

 

 

Task 1 - Setting up the network

 Make sure to use this unique network number throughout the Performance Assessment where indicated by an underscore.

You will be using Variable Length Subnet Mask (VLSM) for this performance assessment and throughout the term.

In Packet Tracer wire the following network.  You will be adding two additional PCs and connect Sw1 and Sw2.  You will also be adding an Access Point and Tablet.

 

 

 

 

 

Program the network with the below information- some of the devices will already be configured if you are using your file from the previous performance assessment.  Don't forget to configure your sub-interfaces for R2 and R3 per the table. 

You will notice G0/0/0.10 and G0/0/0.20 on R2 are missing portions of their IP address and subnet mask.  Like you did in the first Networking Review Performance Assessment, you will need to fill these in by determining an IP address and subnet mask.  Keep in mind you need to support at least 65 users for G0/0/0.10 and at least 50 users for G0/0/0.20.

Here is how you would create the sub-interfaces for R2 and R3:

 

R2(config)# interface G0/0/0

R2(config-if)# no ip address

R2(config-if)# no shutdown

R2(config-if)# interface G0/0/0.10

R2(config-subif)# encapsulation dot1Q 10

R2(config-subif)# ip address 10.___.1.### 255.255.255.###

R2(config-subif)# interface G0/0/0.20

R2(config-subif)# encapsulation dot1Q 20

R2(config-subif)# ip address 10.___.1.### 255.255.255.###

 

R3(config)# interface G0/0/0

R3(config-if)# no ip address

R3(config-if)# no shutdown

R3(config-if)# interface G0/0/0.10

R3(config-subif)# encapsulation dot1Q 10

R3(config-subif)# ip address 10.___.2.1 255.255.255.128

R3(config-subif)# interface G0/0/0.20

R3(config-subif)# encapsulation dot1Q 20

R3(config-subif)# ip address 10.___.2.129 255.255.255.128

 

Don't forget to configure the other interfaces as well!

 

SystemPortConnect ToIP addressSubnet MaskClock Rate/Users
R1 Se0/1/0R210._52__.5.1255.255.255.252500000
 Se0/1/1R310._52__.5.10255.255.255.252 
      
R2G0/0/0.10Sw110._52_.1.###255.255.255.###65 users
 G0/0/0.20Sw110._52_.1.###255.255.255.###50 users
 Se0/1/1R310._52__.5.5255.255.255.252500000
 Se0/1/0R110._52__.5.2255.255.255.252 
      
R3G0/0/0.10Sw310.___.2.1255.255.255.128100 users
 G0/0/0.20Sw310.___.2.129255.255.255.128100 users
 Se0/1/1R110.___.5.9255.255.255.252500000
 Se0/1/0R210.___.5.6255.255.255.252 

 

Now you will be programming Sw1, Sw2, and Sw3 with the VLANs for your network.  Program each switch as follows

            Sw1(config)# interface range f0/1-11

Sw1(config-if-range)# switchport mode access

Sw1(config-if-range)# switchport access vlan 10

Sw1(config-if-range)# exit

Sw1(config)# interface range f0/12-24

Sw1(config-if-range)# switchport mode access

Sw1(config-if-range)# switchport access vlan 20

Sw1(config-if-range)# exit

Sw1(config)# interface range g0/1-2

Sw1(config-if-range)# switchport mode trunk

 

Sw2(config)# interface range f0/1-11

Sw2(config-if-range)# switchport mode access

Sw2(config-if-range)# switchport access vlan 10

Sw2(config-if-range)# exit

Sw2(config)# interface range f0/12-24

Sw2(config-if-range)# switchport mode access

Sw2(config-if-range)# switchport access vlan 20

Sw2(config-if-range)# exit

Sw2(config)# interface range g0/1-2

Sw2(config-if-range)# switchport mode trunk

 

Sw3(config)# interface range f0/1-11

Sw3(config-if-range)# switchport mode access

Sw3(config-if-range)# switchport access vlan 10

Sw3(config-if-range)# exit

Sw3(config)# interface range f0/12-24

Sw3(config-if-range)# switchport mode access

Sw3(config-if-range)# switchport access vlan 20

Sw3(config-if-range)# exit

Sw3(config)# interface range g0/1-2

Sw3(config-if-range)# switchport mode trunk

 

 

 

Set up the EIGRP routing protocol on each router

            R1(config)# router EIGRP 100

            R1(config-router)# network 10.0.0.0

 

R2(config)# router EIGRP 100

            R2(config-router)# network 10.0.0.0

 

R3(config)# router EIGRP 100

            R3(config-router)# network 10.0.0.0

 

Plug the Access Point into F0/12 of Sw3 switch (VLAN 20).

 

Connect the FTP server to the F0/2 port on the Sw3 switch (VLAN 10) and give it an address of 10.___.2.20 255.255.255.128 and a default gateway of 10___2.1.  Verify that you can ping from the R1 router to the FTP server by pinging to the 10.___.2.20 address.  Take a screenshot.

 

Connect the other server to the F0/3 port on the Sw3 switch (VLAN 10) and give it an address of 10.___.2.10 255.255.255.128 and a default gateway of 10___2.1.    Verify you can ping this server by pinging the pinging to the 10.___.2.10 address from the R1 router.  Take a screenshot.

 

We will now set up a DHCP service on the R2 router for the PCs and on the R3 router for the wireless network.

On the R2 router program the following:

            R2(config)# ip dhcp excluded-address 10.___.1.1 10.___.1.9

            R2(config)# ip dhcp excluded-address 10.___.1.129

            

R2(config)# ip dhcp pool mypool

            R2(dhcp-config)# network 10.___.1.### 255.255.255.###

            R2(dhcp-config)# default-router 10.___.1.###

            R2(dhcp-config)# dns-server 10.___.2.10

            

R2(config)# ip dhcp pool mypool2

            R2(dhcp-config)# network 10.___.1.### 255.255.255.###

            R2(dhcp-config)# default-router 10.___.1.###

            R2(dhcp-config)# dns-server 10.___.2.10

            

R3(config)# ip dhcp excluded-address 10.___.2.129

 

R3(config)# ip dhcp pool mypool3

            R3(dhcp-config)# network 10.___.2.128 255.255.255.128

            R3(dhcp-config)# default-router 10.___.2.129

            R3(dhcp-config)# dns-server 10.___.2.10

 

Pull new IP addresses to each of the PCs and the wireless tablet.

 

Verify that your pools are in the routers by typing show run.  Take a screenshot of the pools from the top of the show run command.

 

Verify that you can ping from PC4 to the server at 10.___.2.10 and 10.___.2.20.  Take a screenshot.

 

Deliverables for Task 1

  • Screenshot of your DHCP pools from R2 and R3 (show run will show your pools)
  • Screenshot of a ping from R1 to the servers at 10.___.2.10 and 10.___.2.20
  • Screenshot of a ping from PC4 to the servers at 10.___.2.10 and 10.___.2.20

 

PASTE SCREENSHOTS BELOW

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Task 2 - Setup FTP and TFTP server

Now you will be setting up FTP and TFTP servers to save configurations for the routers.

First add a second NIC to the FTP Server. Power off the server and drag a second NIC (PT-HOST-NM-1CGE) into the bottom slot on the server.

           

Open the server and go to the services tab.  Select the FTP service.

 

Turn the service on and add the username student with the password password. Check Write, read, delete, rename and list as permissions and click the add button.

 

 

Go to the PC1 system and open a terminal to the R1 router (console from PC1 to R1).  From the terminal type the following

                R1# configure terminal

R1(config)# ip ftp username student

R1(config)# ip ftp password password

R1(config)# exit

R1# copy running-config ftp

 Address or name of remote host []? 10.___.2.20

 Destination filename [R1-confg]? R1-config

 

Move the cable to each of the other routers and perform the same functions changing the filename to R2-config and R3-config.

If you go back to the server, you will now see the three configuration files for the routers in the FTP services tab. Take a screenshot of the saved config files.

 

 

Let's try to reverse the process for each router. 

R1# copy ftp running-config

Address or name of remote host []? 10.___.2.20

Source filename []? R1-config

Destination filename [running-config]?

 

 

 

 

 

Now we're going to make a new copy of the R1 router.  Drag a new 4321 router onto the Packet Tracer screen and connect from the G0/0/0 port to the second NIC on the ftp server.  Put a NIM-2T card in the far left slot of the router so it has the same configuration as the current R1 router.

 

Program the FTP_server with the IP address 192.168.1.10/24 for the 2nd NIC (GigabitEthernet1). Use the drop down menu to navigate to this NIC.  You will receive a warning after configuring this NIC- hit OK.

                

Program the router with the following network

                Router> enable

                Router# configure terminal

                Router(config)# ip ftp username student

                Router(config)# ip ftp password password

                Router(config)# interface G0/0/0

                Router(config-if)# ip address 192.168.1.1 255.255.255.0

                Router(config-if)# no shutdown

                Router(config-if)# end

 

Copy the configuration file from the FTP server to the new router              

 

Router# copy ftp running-config

                Address or name of remote host  []? 192.168.1.10

                Source filename  []? R1-config

                Destination filename [running-config]?

 

Verify the new router is now an exact copy of the existing R1 router by doing a show run command on the new router.  Take a screenshot.

 

Replace the R1 router with the new router by moving the serial cables from the R1 router to the new router.  Remove the link from your server and move it to the new router.   Pull a show ip route on the new router.  Take a screenshot.

 

TFTP works the same way as FTP without the need for a username and password.  Verify the TFTP server is running.

 

 

Repeat the steps you used for the FTP server without the need to configure the username and password.

 

 R1# copy running-config tftp

 Address or name of remote host []? 10.___.2.20

 Destination filename [R1-confg]? R1-config

 

Move the cable to each of the other routers and preform the same functions changing the filename to R2-config and R3-config.

If you go back to the server, you will now see the three configuration files for the routers in the TFTP services tab.  Take a screenshot of the saved config files.

 

 

 

 

 

 

Deliverables for Task 2

  • Screenshot of saved FTP config files
  • Screenshot of show run for new R1 router
  • Screenshot of show ip route from new R1 router
  • Screenshot of saved TFTP config files

PASTE SCREENSHOTS BELOW

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Task 3 - SSH and Telnet

 

You will now set up SSH and Telnet communications on the routers.  This is the typical way network administrators set up their systems so they can communicate to each router from a central location.  Otherwise you will need to physically travel to each router with your laptop and a console cable.

You will set up SSH for communications across the network. You will need to do the following for each router on the network.

  1. Create secret password on the router or switch

R1(config)#enable secret cisco

2. Open the router R1 console line and create domain and logon user name.

R1(config)#ip domain-name ecpi.local
R1(config)#username student password class

2. Now we are going to create the crypto key for the SSH session.

R1(config)#crypto key generate rsa 
The name for the keys will be: R1.Technig.com
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.

How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

3. Now enable SSH version 2, set time out duration and login attempt time on the router. Remember this message if you are going to use ssh version 2 "Please create RSA keys (of at least 768 bits size) to enable SSH v2."

R1(config)#ip ssh version 2
R1(config)#ip ssh time-out 50
R1(config)#ip ssh authentication-retries 4

4. Enable vty lines and configure access protocols.

R1(config)#line vty 0 4
R1(config-line)#transport input all 
R1(config-line)#login local
R1(config-line)#logging synchronous 
R1(config-line)#motd-banner 
R1(config-line)#exit

 

Testing Connectivity

From a PC verify that can ping the router.

 

 

Open the command prompt and type ssh -l student 10.___.5.1 then press enter.  Your initial password is class and then enable password is cisco.

 

 

 

Open the command prompt and type telnet 10.___.5.1 then press enter. Your username is student, initial password is class and then enable password is cisco.

 

 

What is the different between telnet and SSH?

 

 

finish this task for each router.  The router IPs you can use are at 10.___.5.1, 10.___.5.5, and 10.___.5.9

Take a screenshot of each SSH and Telnet login to each router.

 

Deliverables for task 3

  • Screenshot of ping to each router on the network
  • Screenshot of SSH and Telnet to each router on the network
  • Answer the question about Telnet vs SSH

 

PASTE SCREENSHOTS BELOW


























Step by Step Solution

There are 3 Steps involved in it

Step: 1

blur-text-image

Get Instant Access to Expert-Tailored Solutions

See step-by-step solutions with expert insights and AI powered tools for academic success

Step: 2

blur-text-image

Step: 3

blur-text-image

Ace Your Homework with AI

Get the answers you need in no time with our AI-driven, step-by-step assistance

Get Started

Recommended Textbook for

International Marketing And Export Management

Authors: Gerald Albaum , Alexander Josiassen , Edwin Duerr

8th Edition

1292016922, 978-1292016924

More Books

Students also viewed these Computer Network questions