Question
Router A and Router B are connected and both are running OSPF protocol. The following is a sample configuration from Router A: interface
Router A and Router B are connected and both are running OSPF protocol. The following is a sample configuration from Router A:
interface FastEthernet0/0
ip address 10.10.3.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.100.1.1 255.255.255.0
duplex auto
speed auto
!
ip route 172.16.0.0 255.255.0.0 Null 0
!
router ospf 200
network 10.0.0.0 0.255.255.255 area 0
redistribute static subnets
!
The following is a sample configuration from RouterB:
interface FastEthernet0/0
ip address 10.10.3.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.10.1 255.255.255.0
duplex auto
speed auto
!
router ospf 200
network 10.0.0.0 0.255.255.255 area 0
redistribute connected subnets
What routes are redistributed from Router A's and Router B's perspectives? What would be the effect of using the redistribute connected instead of redistributing connected subnets on Router B?
From the show ip route output and the configuration of Router A, reconstruct the rough network diagram from the point of view of Router A. Label the interfaces and draw the connections to other router(s). Specify the network learned from the connected router(s).
############Configuration File####################
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterA
!!
interface FastEthernet0/0
ip address 192.168.3.1 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.1.1 255.255.255.252
clock rate 2000000
!
interface FastEthernet0/1
ip address 10.100.1.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 200
network 10.0.0.0
network 192.168.0.0 0.0.255.255
no auto-summary
!
############IP Route####################
RouterA#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter
area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external
type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 -
IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user
static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
D 10.8.8.0/23 [90/2172416] via 192.168.1.2, 00:05:30,
Serial0/0
C 10.100.1.0/24 is directly connected, FastEthernet0/1
D 10.200.1.0/24 [90/30720] via 192.168.3.2, 00:14:04,
FastEthernet0/0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, Serial0/0
192.168.3.0/30 is subnetted, 1 subnets
C 192.168.3.0 is directly connected, FastEthernet0/0
RouterA#
LAN_A 10.100.1.0/24 RouterA f0/1 192.168.1.1/30 s0/0 f0/0 192.168.3.1/30 192.168.3.2/30 f0/1 RouterB 192.168.1.2/30 LAN_B s0/1 RouterC LAN_C
Step by Step Solution
There are 3 Steps involved in it
Step: 1
Get Instant Access to Expert-Tailored Solutions
See step-by-step solutions with expert insights and AI powered tools for academic success
Step: 2
Step: 3
Ace Your Homework with AI
Get the answers you need in no time with our AI-driven, step-by-step assistance
Get Started